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General Introduction 

 

Microsoft Excel is a spreadsheet software program that is part of the Microsoft Office 

productivity suite. For versions of Excel released prior to 2007, files are saved with the 

“.XLS” extension, while versions from 2007 onward use the “.XLSX” extension, reflecting 

updates to the file format and capabilities. Over the years, Excel has become one of the most 

widely used software applications across the globe, both in professional environments and 

for personal use. 

Excel offers a wide range of functionalities, including the ability to create calculation 

tables, invoices, charts, schedules, graphs, and databases, among others. One of its key 

strengths is the automation of calculations through the use of formulas, which allows users 

to perform complex operations quickly and efficiently. 

This type of application is generally known as a spreadsheet program. A spreadsheet 

program enables users to manipulate numerical data easily and to perform automatic 

calculations based on numbers stored within a structured table format. In addition to 

handling numbers, spreadsheet programs like Excel also make it straightforward to create 

visual representations of data, such as bar charts, line graphs, and pie charts, providing 

deeper insights at a glance. 

This handout is designed to help beginners get a firm grasp on the basics of Excel. It 

will guide you through the initial steps of using the software, including inputting and 

formatting data so that it becomes clear, organized, and easy to read. As you progress, you 

will learn more advanced techniques such as using formulas for dynamic calculations, 

sorting and filtering data, and leveraging Excel’s powerful tools to manage and analyze large 

amounts of information efficiently. 

By following this guide, you will gradually build a solid foundation in Excel that will 

not only help you with everyday tasks but also open the door to more advanced uses, such 

as data analysis, project management, financial modeling, and reporting. 
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1.1. Introduction 

To launch Excel, simply double-click on the Excel icon located on the Windows 

desktop. Alternatively, you can click Start (on the taskbar), then Programs, and finally select 

Excel (or Microsoft Office Excel). 

Once Excel is open, the working space you interact with is called a workbook. A 

workbook is the main container where you create and manage your spreadsheets. 

1.2. Workbook 

By default, a workbook contains three worksheets, but it can include up to 255 

worksheets [1], [2]. Each worksheet is identified by a tab located at the bottom of the Excel 

window. 

To add a new worksheet, you can go to the Insert menu and select Worksheet. 

Workbooks allow you to organize large amounts of related data across multiple sheets 

while keeping everything grouped in a single file. 

The workbook contains the following elements, see Figure 1.1: 

1. Account Info 

Displays the name and profile picture of the signed-in Microsoft account. Used to 

manage account settings, switch users, or sign out. 

2. Window Controls 

Includes the Minimize, Maximize/Restore, and Close buttons for the Excel window. 

3. Search Bar 

Allows you to search for commands, help, or content within Excel (“Tell Me” or 

“Search in Excel”). 

4. Comments Button 

Used to add or view comments in the workbook for collaboration or notes. 

5. File Name 

Shows the name of the current Excel file (e.g., Excel interface.xlsx). Also displayed 

on the title bar. 

6. Quick Access Toolbar 
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A customizable toolbar for frequently used commands like Save, Undo, and Redo. 

7. Ribbon Tabs 

Top-level categories (e.g., Home, Insert, Page Layout) that organize related 

commands into tabs. 

8. Font Group 

Contains formatting tools such as font style, size, bold, italic, underline, font color, 

and fill color. 

9. Alignment Group 

Controls how text is aligned in cells — left, center, right, top, middle, bottom, text 

orientation, wrap text, merge cells, etc. 

10. Clipboard Group 

Provides cut, copy, paste, and format painter options for managing content between 

cells or workbooks. 

11. Name Box 

Displays the address of the selected cell (e.g., C3) or the name of a defined range if 

one is selected. 

12. Formula Bar 

Displays the formula or data in the active cell. You can also enter or edit data/formulas 

here. 

13. Column Headers 

Letters (A, B, C, etc.) that label each column. Clicking a header selects the whole 

column. 

14. Row Headers 

Numbers (1, 2, 3, etc.) that label each row. Clicking a number selects the whole row. 

15. Sheet Tab 

Shows the name of each worksheet in the workbook (e.g., Sheet1). Click to navigate 

between sheets. 

16. Insert Sheet Button 
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Click the + icon to add a new worksheet to the workbook. 

17. Status Bar 

Displays information about the current worksheet, such as sum/average/count of 

selected cells, and app status messages. 

18. Vertical Scroll Bar 

Used to scroll the worksheet up and down. 

19. Horizontal Scroll Bar 

Used to scroll the worksheet left and right. 

20. View Buttons 

Switches between different worksheet views: 

− Normal (default view), 

− Page Layout (how it will print), 

− Page Break Preview (shows page divisions). 

21. Zoom Slider 

Lets you zoom in or out of the worksheet to adjust how much content is visible. 

22. Active Cell 

The currently selected cell (highlighted with a green border). It's where your input will 

go when you type. 
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Figure 1.1. Key Elements Labeled. 

1.3. Worksheet 

A worksheet consists of a grid of columns and rows. 

Columns are labeled alphabetically (A, B, C, ..., Z, then AA, AB, etc.), while rows are 

labeled numerically (1, 2, 3, etc.). 

Only a small part of the full worksheet is visible on the screen at any given time 

because an Excel worksheet can contain up to 256 columns and 65,536 rows [3] (in older 

versions; newer versions allow even more). 

1.3.1. Selecting rows and columns 

To select an entire row, place the mouse pointer on the row header until it changes to 

a right-pointing arrow, then left-click to highlight the row. 

To select an entire column, place the mouse pointer on the column header until it 

changes to a downward-pointing arrow, then left-click to highlight the column. 
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1.3.2. Managing worksheets 

Worksheets are powerful tools for organizing and analyzing different sets of data 

within the same project. 

− To rename a worksheet, right-click on the sheet tab and select Rename. 

− To insert a new worksheet, right-click on the sheet tab and choose Insert. 

− To delete a worksheet, right-click on the sheet tab and select Delete. 

 1.4. Cell 

A cell is the intersection of a column and a row. 

Each cell can contain: Text (e.g., labels or headings), Numbers (e.g., quantities or 

measurements), Formulas (e.g., calculations like sums or averages), or a combination of 

these elements. 

Cells are the fundamental building blocks where data is entered and manipulated in 

Excel. 

 1.5. Cell Address 

Knowing the address of a cell is crucial for writing formulas, referencing data, and 

navigating efficiently within a worksheet. 

Each cell has a unique address that identifies its position within the worksheet. 

The address is a combination of the column letter and the row number. 

For example: 

The cell located at the first column and the first row is addressed as A1. 

1.6. Range of Cells 

Ranges are often used for applying formulas, formatting, or creating charts based on 

multiple data points. 

A range refers to a group of two or more adjacent cells. 

For example: 

The range from A1 to A10 includes all the cells vertically between A1 and A10. 

Selecting ranges: 
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To select multiple contiguous cells, click and hold the left mouse button on the first 

cell, then drag the mouse over the other cells to highlight them. 

To select multiple non-contiguous cells, click on the first cell, hold down the CTRL 

key on the keyboard, and click each additional cell you want to include. The selected cells 

will be highlighted in blue. 

1.7. Formulas 

A formula is used to perform numerical calculations such as addition, multiplication, 

etc. A formula always begins with an equal sign (=) and contains cell references or named 

ranges [4]. Arithmetic formulas use one or more arithmetic operators to carry out 

calculations. A cell reference refers to a cell's address or a named range within a formula. 

If you modify the value of a cell, any formula referencing that cell will automatically 

update. When a formula contains multiple arithmetic operators, Excel follows the order of 

operations: 

− Parentheses (highest priority), 

− Exponents (powers), 

− Multiplication & Division (equal priority, evaluated left to right), 

− Addition & Subtraction (equal priority, evaluated left to right). 

Example: 

= C1 * (D5 + F6) - A2 

First, (D5 + F6) is calculated. 

Then, C1 is multiplied by the result. 

Finally, A2 is subtracted. 

1.8. Tables 

Working with Tables in Excel provides flexibility by simplifying formula references, 

making row/column selection easier, and allowing automatic formula replication exploring 

[4]. 
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1.8.1. Creating a Table 

To create a table, see figure 1.2: 

− Select the cell range you want to format as a table. 

− Go to the Home tab, then the Font group. 

− Click on Borders to apply gridlines. 

Customize the border style and color using: 

− Line Color (to choose a color) 

− Line Style (to select dashed, solid, or double lines) 

Figure 1.2. Apply borders to a cell range in Excel. 

Additional Benefits of Tables: 

Formatting Consistency: Tables maintain uniform styling (banded rows, header 

formatting). 

Structured References: Formulas use column names instead of cell references (e.g., 

=SUM(Table1[Sales])). 
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Automatic Expansion: New data added to a table is automatically included in 

formulas. 

1.8.2. Choosing a Table Style 

To change the style of a table in Excel, follow these steps: 

− Select the cell or range of cells within the table that you want to format. 

− Go to the Home tab, and within the Styles group, click on Format as Table. 

− Choose a table style from the gallery. Click on the style you want to apply it 

instantly to your selection. 

By using different table styles, you can quickly improve the readability and 

appearance of your data. Styles also add functionality, such as filtering and sorting options, 

which are automatically included when formatting a range as a table. 

1.9. Inserting a Chart 

A chart in Excel is a visual representation of numerical data, allowing users to easily 

analyze trends, patterns, and comparisons. It transforms rows and columns of numbers into 

graphical elements like bars, lines, or pie slices to make the information clearer and more 

intuitive. 

To create a chart based on your data in Excel, proceed with the following steps, see 

figure 1.3: 

− Select the range of data that you want to visualize in a chart. 

− Click on the Insert tab, then in the Charts group, select Recommended Charts. 

− Under the Recommended Charts tab, browse through the chart types that Excel 

suggests based on the structure of your data. Click on a chart to preview how 

your data will appear. 

− When you find a chart that suits your needs, click OK to insert it into your 

worksheet. 
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1.9.1. Type of Charts 

The common types of charts in Excel are: 

− Column Chart – Displays data as vertical bars; useful for comparing values 

across categories. 

− Bar Chart – Similar to a column chart but with horizontal bars. 

− Line Chart – Shows trends over time by connecting data points with lines. 

− Pie Chart – Displays data as slices of a circle; best for showing proportions or 

percentages. 

− Area Chart – Like a line chart, but the area under the line is filled in; 

emphasizes total values over time. 

− Scatter Plot (XY Chart) – Shows relationships or correlations between two 

variables. 

− Bubble Chart – A variation of a scatter plot where a third variable is 

represented by the size of the bubble. 

− Combo Chart – Combines two different types of charts (e.g., column and line) 

in a single chart for richer analysis. 

− Histogram – Shows the distribution of data by grouping values into ranges 

(bins). 

− Waterfall Chart – Visualizes cumulative effects of sequential positive and 

negative values. 
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Figure 1.3. Create chart in Excel. 

1.9.2. Customizing the Chart 

To customize the chart, use the following instructions: 

− Use the small buttons near the upper-right corner of the chart: 

− Chart Elements (the plus sign) to add features like axis titles, data labels, a 

legend, and more; 

− Chart Styles (the brush icon) to quickly change the design, colors, and layout; 

− Chart Filters (the funnel icon) to refine which data series and categories are 

displayed. 

− For more advanced design and formatting options: 

− Click directly on the chart to activate the Chart Tools in the ribbon. 

− Use the Design and Format tabs to further customize the look and feel of your 

chart changing layouts, adjusting colors, modifying individual elements, and 

applying special effects. 

− Creating and customizing charts in Excel allows you to present your data in a 

clear, attractive, and professional way, making it easier to interpret and 

analyze. 
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1.10. Insert a Header or Footer 

Header: The section at the top of each printed page in Excel where you can include 

information such as the document title, author name, or page number. 

Footer: The section at the bottom of each printed page used to display information like 

the date, file name, or total number of pages. 

These elements are primarily used for printed documents and do not appear in the 

main worksheet view. 

1) Open Header and Footer View 

− Go to the Insert tab. 

− Click Text > Header & Footer. 

− This switches your sheet to Page Layout View where you can edit headers and 

footers. 

 

Figure 1.4. Header and Footer in Excel. 

2) Add Header 

− Click the top area labeled “Click to add header”. 

− You will see three sections: 

− Left section → Add your name or logo. 

− Center section → Add a title like “Sales Report”. 
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− Right section → Add a date or page number. 

− You can use the Header & Footer Tools > Design tab to insert: 

− Date: Insert Date 

− Time: Insert Time 

− Page Number: Page Number 

− File Name: File Name 

− Sheet Name: Sheet Name 

3) Add Footer 

Scroll to the bottom of the sheet or use the Go to Footer button. 

Same structure as the header: left, center, and right. 

Add items like: 

− © 2025 

− Confidential 

− Page 1 of 5 

4) Exit Header/Footer Mode 

Click anywhere in the sheet or go to View > Normal to return to normal view. 

Preview Header and Footer: 

Go to File > Print or press Ctrl + P to see how the header and footer appear when 

printed. 

1.11. Exercises 

1.11.1. Exercise 1 

1) Open a new Excel workbook and save it as "Monthly_Budget.xlsx". 

2) Create a table with the following columns starting from row 5: 

Category, Planned Amount, Actual Amount, Difference 

3) Enter at least five categories (e.g., Rent, Food, Transportation, Utilities, Entertainment). 
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4) In the Difference column, enter a formula to calculate: 

Difference = Planned Amount - Actual Amount 

5) Format the currency values using a consistent currency. 

6) Add a row at the bottom of the table to show the Total for each numeric column. 

7) Use conditional formatting to highlight: 

− Positive differences in green 

− Negative differences in red 

8) Insert a column chart that shows Planned vs. Actual spending by category. 

9) Add a title in cell B2, merged across B to D, labeled "Monthly Budget Tracker". Make it 

bold, font size 16, and with a background color. 

10) Add a custom header: 

− Left: Your name 

− Center: "Monthly Budget" 

− Right: Date 

11) Rename the worksheet to "Budget Template" and duplicate it to track multiple months. 

12) Preview before printing to ensure the entire budget fits on one page. 

1.11.2. Exercise 2 

1) Open a new workbook and save it as Inventory_Tracker.xlsx. 

2) Enter the following table starting from cell A1: 

Product ID Product Name Category Quantity Unit Price Total Value 

101 Mouse Electronics 50 10.00 
 

102 Keyboard Electronics 30 20.00 
 

103 Notebook Stationery 100 2.50 
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3) Adjust the width of all columns for clear visibility. 

4) Use Calibri font, size 12 for the entire sheet. 

5) Bold the column titles and apply a light grey background. 

6) In the Total Value column, insert a formula to calculate: 

− Quantity × Unit Price 

7) Format the Total Value and Unit Price columns as currency. 

8) Add a header: 

− Left: Your Name 

− Center: "Inventory Tracker" 

− Right: Date 

9) Create borders for the entire table. 

10) Add Data Validation in the Category column to only allow: "Electronics", "Stationery", 

"Office". 

11) Rename the worksheet tab to "Inventory". 

12) Save and ensure the sheet is print-ready on one page. 

1.11.3. Exercise 3 

Creating and customizing charts in Excel allows you to present your data in a clear, 

attractive, and professional way, making it easier to interpret and analyze. 

The company INFORAMA currently generates its invoices manually. This company 

now wishes to create its invoices using Excel. You are asked to replicate the invoice template 

below in Excel and to automate the calculations as much as possible. 
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1) Build the invoice template above following the following instructions: 

a) Open a new workbook, save it as TP4. 

b) Enter the content of the invoice. 

c) Adjust the width of columns B to 10, and E to 12. 

d) Make the column titles two lines, centered and bold. 

e) Use Calibri font, size 12 for the entire sheet. 

f) Create the border layout following the border style. 

g) Insert the title "Automated Invoice" in the cell range C4: D4, highlight it with color, 

make it bold, and set the font size to 14. 

h) Set a custom footer: 

Left Section: First and Last Name 

Center Section: TP Name 
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Right Section: Group and Date 

2) Rename Sheet 1 to "Template", duplicate this tab every time you need to create an 

invoice, in order to keep the original template blank. 

3) Preview the print to verify that your invoice fits on one page. 

4) Enter the formulas to perform the necessary calculations:  

Total Amount (F11),  

Total (F17), Discount (F18), 

 Total Excluding Tax (F19),  

VAT (F20), 

Total Including Tax (F21). 

5) Protect your workbook with a password. 

1.12. Solution of the exercises  

1.12.1. Solution of Exercise 1 

1) Open a new Excel workbook and save it 

Open Excel → File → Save As → Name the file "Monthly_Budget.xlsx". 

2) Create a table starting from row 5 

− In row 5, enter the headers in cells A5:D5: 

− A5: Category 

− B5: Planned Amount 

− C5: Actual Amount 

− D5: Difference 

3) Enter at least five budget categories 

In cells A6:A10, enter: 

− Rent 

− Food 
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− Transportation 

− Utilities 

− Entertainment 

4) Enter the formula for Difference 

In D6, enter:       = B6 - C6 

Drag the formula down from D6 to D10. 

5) Format currency values 

− Select columns B, C, and D. 

− Right-click → Format Cells → Choose Currency format (DA). 

6) Add totals 

In row 11, under the respective columns: 

− A11: Total 

− B11: = SUM(B6:B10) 

− C11: = SUM(C6:C10) 

− D11: = SUM(D6:D10) 

7) Apply conditional formatting to "Difference" column 

− Select D6:D10 

− Go to Home → Conditional Formatting → New Rule 

− Rule 1: Format cells greater than 0 → green fill 

− Rule 2: Format cells less than 0 → red fill 

8) Insert a column chart 

− Select range A5:C10 

− Go to Insert → Column Chart → Choose Clustered Column 

− Add chart title: "Planned vs Actual Spending" 
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9) Add a main title 

− In cell B2, type: Monthly Budget Tracker 

− Merge cells B2 to D2 

− Apply: 

− Bold 

− Font size: 16 

− Background fill color (e.g., light blue) 

10) Add a custom header 

− Go to Insert → Text → Header & Footer 

− In the header area: 

− Left section: Your full name 

− Center section: "Monthly Budget" 

− Right section: Use the Insert Date button 

11) Rename the sheet 

− Right-click on Sheet1 → Rename to "Budget Template" 

− To duplicate: Right-click on the tab → Move or Copy → Create a copy 

12) Print preview 

Go to File → Print → Check that the page fits well 

1.12.2. Solution of Exercise 2 

1) Open Excel and Save the Workbook 

− Launch Excel. 

− Go to File > Save As and name the file: Inventory_Tracker.xlsx. 

2) Enter the Table 

In cell A1, enter the headers: 
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    A                      B          C                 D                   E                      F 

Product ID Product Name    Category Quantity Unit Price Total Value 

Then fill the data from row 2 to 4: 

− A2: 101, B2: Mouse, C2: Electronics, D2: 50, E2: 10.00 

− A3: 102, B3: Keyboard, C3: Electronics, D3: 30, E3: 20.00 

− A4: 103, B4: Notebook, C4: Stationery, D4: 100, E4: 2.50 

3) Adjust Column Widths 

− Select columns A–F → Right-click → Column Width: 

− Set a comfortable width (e.g., 15–20 units depending on content). 

4) Set Font and Size 

− Select the whole sheet: Ctrl + A 

− Go to the Home tab → Font section: 

− Font: Calibri 

− Size: 12 

5) Format Column Titles 

− Select Row 1 (A1:F1) 

− Click Bold 

− Fill with light grey color: Home > Fill Color 

6) Insert Formula in “Total Value” 

− In F2, write:  = D2*E2 

− Then drag down to F3 and F4. 

7) Format Currency 

− Select columns E and F 

− Go to Home > Number Format → Choose Currency 

8) Insert Header 
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− Go to Insert > Text > Header & Footer 

− Click on the header area: 

− Left section: Type your name 

− Center section: Type Inventory Tracker 

− Right section: Use Insert Date or type the current date 

9) Add Borders 

− Select your table (A1:F4) 

− Go to Home > Borders → Choose All Borders 

10) Apply Data Validation 

− Select column C (C2 to C100, for example) 

− Go to Data > Data Validation: 

− Allow: List 

− Source: Electronics, Stationery, Office 

11) Rename Worksheet 

− Right-click on the sheet tab → Choose Rename 

− Type: Inventory 

12) Prepare for Printing 

− Go to File > Print 

− In Scaling, choose: Fit Sheet on One Page 

− Check the preview to ensure everything fits well. 

1.12.3. Solution of Exercise 3 

1) Build the invoice template by following the instructions below: 

a) Open a new workbook and save it as TP4 

− Open Excel 

− Click File > Save As 
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− Name it TP1.xlsx and choose the desired folder. 

This step creates the working file. 

b) Enter the content of the invoice 

c) Adjust the width of columns B and E 

− Right-click on column B, select Column Width, enter 10 

− Right-click on column E, set width to 12 

d) Make the column titles two lines, centered and bold 

In cell C10 for example, type: 

− Unit Price → Use Alt + Enter between the two words to insert a line break. 

− Select the header row (e.g., C10:F10) 

− Click Bold 

− Use Center alignment 

e) Use Calibri font, size 12 

− Press Ctrl + A to select the whole sheet. 

− On the Home tab: 

− Set font to Calibri 

− Set size to 12 

− Standardizes the entire sheet. 

f) Create the border layout 

− Select all cells involved in the invoice 

− Use Borders tool (Home tab): 

− Apply All Borders 

− For totals section, apply Thick Outside Borders 

g) Insert the title "Automated Invoice" 

− Use cells C4:D4 
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− Select and merge the cells: Home > Merge & Center 

− Enter: Automated Invoice 

− Set font size: 14 

− Make it bold 

− Fill with a background color (e.g., light gray or blue) 

Creates a clear and professional title for your invoice. 

h) Set a custom footer 

− Go to Page Layout > Page Setup > Header/Footer > Custom Footer 

− Fill in: 

− Left section: Your first and last name 

− Center section: TP4 

− Right section: Group + Date 

2) Rename Sheet1 to "Template" 

− Right-click on the sheet tab (Sheet1) 

− Choose Rename 

− Enter: Template 

Duplicate the template for new invoices 

− Right-click on the tab Template 

− Choose Move or Copy 

− Check "Create a copy", then OK 

This keeps the original template blank and reusable. 

3) Preview before printing 

− Go to File > Print 

− Ensure that the content fits on one page 

− Use Scaling option: Fit Sheet on One Page 
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− Ensures your invoice prints cleanly on one page. 

4) Enter formulas for calculations 

Cell Label                     Formula (in column F) 

F17 Total Amount         =SUM(F11:F13) 

F18 Discount (10%)      =F14*0.10 

F19 Total excl. tax         =F14-F15 

F20 VAT (20%)         =F16*0.20 

F21 Total incl. tax         =F16+F17 

5) Protect your workbook with a password 

− Go to Review > Protect Workbook 

− Choose to add a password. 

1.13. Conclusion 

In summary, launching Excel is straightforward, and understanding its core 

component, the workbook, is essential. The workbook serves as the foundation for creating, 

organizing, and analyzing data in spreadsheets, making it the starting point for all tasks in 

Excel. With this knowledge, users are ready to explore the powerful features Excel offers 

for data management and analysis. 
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2.1. Introduction 

Microsoft Excel is one of the most widely used tools for data organization, analysis, 

and reporting. Two of its essential features, filtering and sorting, allow users to navigate and 

manage large datasets efficiently. Filtering enables users to temporarily hide non-relevant 

data based on specific criteria, while sorting helps arrange the data in a logical order. 

Mastering these functions is crucial for anyone who regularly works with structured data, 

whether in business, education, or research contexts. 

2.2. A Filters in Excel 

Filtering is a powerful Excel feature that allows users to temporarily hide rows in a 

dataset based on specific criteria, without deleting any data [5]. This is useful for quickly 

narrowing down data to what's relevant at the moment. 

2.2.1. How to Create a Filter 

To apply filters to a dataset, follow these steps, see figure 2.1: 

− Select the row that contains the column headers. 

− Click the row number on the left to select the entire row. 

− Enable the filter functionality: 

− Go to the “Data” tab on the ribbon. 

− Click on the “Filter” button (you may see a funnel icon). 

− This will insert a drop-down arrow next to each column header. 

− Each of these arrows lets you apply a filter to the respective column by 

selecting specific values or defining criteria. 

2.2.2. Types of Filter Criteria 

You can filter your data based on different criteria depending on the data type in the 

column: 

a. Text Filters 

Use when the column contains words or text. 

Options include: 

− "Contains" 
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− "Does Not Contain" 

− "Begins With" 

− "Ends With" 

− "Equals" 

 

Figure 2.1. Filter in Excel. 

 

b. Number Filters 

Use when the column contains numerical data (including dates). 

Options include: 

− Greater Than / Less Than 

− Between 

− Top 10 

− Equals / Does Not Equal 
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c. Color Filters (only in some Excel versions) 

Filters based on cell color or text color. 

Useful if you've highlighted data visually and want to focus on certain highlighted 

cells. 

d. Combining Filters 

You can filter multiple columns simultaneously. 

For example, you might filter one column to show only a specific category and another 

to show only values above a certain number. 

2.2.3. Removing Filters 

You can remove filters in two ways: 

a. To remove a filter from a specific column: 

− Click the filter drop-down arrow in the column header. 

− Choose “Clear Filter From [Column Name]” or check “Select All”. 

b. To remove all filters from the table: 

− Go back to the "Data" tab and click the "Filter" button again to turn it off. 

− This will remove the filter arrows and display all rows in the table. 

 

2.3. Sorting in Excel 

Sorting means arranging data in a particular order based on one or more columns. 

Unlike filtering, sorting doesn’t hide any data; it simply rearranges the rows [6]. 

Sorting is useful when: 

− You want to list items alphabetically. 

− You want to rank numbers from largest to smallest. 

− You want to organize dates chronologically. 
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Steps to Sort a Table, see figure 2.2: 

− Select the entire data range, including the row with column headers. 

− Go to the “Data” tab. 

− Click “Sort” (not the A→Z or Z→A shortcuts if you want advanced sorting). 

In the Sort window: 

− Choose the column you want to sort by. 

− Select the order: 

− A to Z (alphabetical or smallest to largest) 

− Z to A (reverse order or largest to smallest) 

− Click OK to sort the data. 

 

 

Figure 2.2. Sort in Excel. 
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2.4. Exercises 

2.4.1. Exercise 1 

Create the following table in Excel 

Date Region Salesperson Product Units Sold Revenue 

2025-01-01 East Amina Laptop 5 2500 

2025-01-02 West Bachir Phone 10 3000 

2025-01-03 East Kamila Tablet 7 1400 

2025-01-04 South Amina Laptop 3 1500 

2025-01-05 North Bachir Phone 8 2400 

2025-01-06 West Kamila Laptop 6 3000 

2025-01-07 East Amina Tablet 9 1800 

 

1) Apply a filter to the header row. 

2) Filter the Region to show only East. 

3) What are the total Units Sold for the East region? 

4) Clear previous filters. 

5) Filter to show only rows where: 

− Product is “Laptop” 

− Revenue is greater than 2000 

6) How many rows match these criteria? 

7) Clear previous filters. 

8) Filter the Salesperson column to show only names that start with “A”. 

9) How many rows do you see? 
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2.4.2. Exercise 2 

Name Department Salary Performance Rating Hire Date 

Amina HR 55000 3.8 15-03-2024 

Bachir Sales 62000 4.1 10-11-2024 

Chokri IT 72000 4.5 22-07-2024 

Dalila HR 51000 3.2 05-01-2024 

Dounia Sales 58000 4.0 30-06-2024 

Fatima IT 68000 4.3 18-09-2024 

Kamel HR 53000 3.9 12-05-2024 

 

1) Sort the data so the employee with the highest salary appears at the top. 

2) First sort alphabetically by Department, within each department, sort by Name 

alphabetically. 

3) Sort by Hire Date (Oldest to Newest) 

4) Sort the list so the longest-serving employee is listed first. 

5) Sort by Performance Rating (Low to High) 

6) Sort the data to see who has the lowest performance rating at the top. 

2.4.3. Exercise 3 

Here are the temperatures recorded in the main cities of Algeria on September 15, 2023. 

Oran   21°   32°    North West                   Tlemcen   21°   31°    North West 

Biskra  29°  39°    Center East        Mostaganem   20°   29°    North West 

Mascara 18°   34°    North West                Chlef   23°   35°    North West 

Sid Bel Abbés  18°  33°    North West      Médéa   22°   30°    South West 

Constantine    22°   32°    East                   Sétif   21°   32°    East 

Bejaïa    24°  32°    East                             Annaba  22°   31°    North  
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Alger  26°  33°    North                             Ghardaïa   29°   41°    South 

Ouargla    28°   43°    South                      Tamanrasset  21°   34°    South 

Bouira   24°  36°    Center East       Tindouf  28°   41°    South West 

Batna  19°   35°    North West                   Adrar  27°   44°    South West 

1) Enter the data for Algeria into a table. There will be four columns: City, Minimum 

Temperature, Maximum Temperature, Location.  

2) In a fifth column, calculate the temperature difference for each city.  

3) Select the entire table and sort it according to the criterion in column 1, in descending 

order.   

4) Sort the table based on the 3 sorting criteria: Minimum Temperature - Ascending, 

Maximum Temperature - Descending, and City - Ascending.  

5) Display only the cities where the maximum temperature is between 30° and 35°.  

6) Display only the cities in the northwest with a minimum temperature of 21°.  

7) Display the cities from the south or north with a maximum temperature between 40° 

and 45°. 

8) Display all cities that start with the letter A. 

2.5. Solution of the exercises 

2.5.1. Exercise 1 

1) 

a. Click anywhere in the table. 

b. Go to the Data tab. 

c. Click Filter, arrows appear in the header row. 

d. Click the filter arrow in the Region column. 

e. Uncheck all, then check only East. 

f. Click OK. 
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2) The result is:     

Date Region Salesperson Product Units Sold Revenue 

2025-01-01 East Amina Laptop 5 2500 

2025-01-03 East Kamila Tablet 7 1400 

2025-01-07 East Amina Tablet 9 1800 

 

3)  Total Units Sold:     =SUMIFS(E2:E8, B2:B8, "East") 

4) Clear all filters using the Clear button on the Data tab. 

5) 

− Click the filter arrow in the Product column. 

− Select only Laptop, then click OK. 

− Click the filter arrow in the Revenue column. 

− Choose Number Filters > Greater Than... 

− Type 2000 and click OK. 

Result is: 

Date Region Salesperson Product Units Sold Revenue 

2025-01-01 East Alice Laptop 5 2500 

2025-01-06 West Charlie Laptop 6 3000 

 

6) Number of Rows: 2 rows. 

7) Clear previous filters. 

8) 

a. Click the filter arrow in the Salesperson column. 

b. Choose Text Filters > Begins With … 

c. Type A and click OK. 
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Result is: 

Date Region Salesperson Product Units Sold Revenue 

2025-01-01 East Alice Laptop 5 2500 

2025-01-04 South Alice Laptop 3 1500 

2025-01-07 East Alice Tablet 9 1800 

 

9) Number of Rows:  3 rows 

2.5.2. Exercise 2 

1) 

Select the entire table (including headers). 

− Go to the Data tab. 

− Click Sort. 

− Choose: Sort by: Salary, Sort On: Values, Order: Largest to Smallest 

− Click OK 

2) 

− Select the whole table. 

− Go to Data > Sort. 

− Set the first level: Sort by: Department | A to Z > Click Add Level 

− Set the second level: Then by: Name | A to Z 

− Click OK 

3) 

− Select the table. 

− Click Sort from the Data tab. 

− Sort by: Hire Date > Order: Oldest to Newest 

− Click OK 
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4) 

− Select the table. 

− Click Sort from the Data tab. 

− Sort by: Performance Rating > Order: Smallest to Largest 

− Click OK 

2.5.3. Exercise 3 

1) Create a table with 4 columns: 

City Min Temp Max Temp Location 

Oran 21 32 North West 

Tlemcen 21 31 North West 

Biskra 29 39 Center East 

Mostaganem 20 29 North West 

Mascara 18 34 North West 

Chlef 23 35 North West 

Sid Bel Abbés 18 33 North West 

Médéa 22 30 South West 

Constantine 22 32 East 

Sétif 21 32 East 

Bejaïa 24 32 East 

Annaba 22 31 North 

Alger 26 33 North 

Ghardaïa 29 41 South 

Ouargla 28 43 South 

Tamanrasset 21 34 South 

Bouira 24 36 Center East 

Tindouf 28 41 South West 
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Batna 19 35 North West 

Adrar 27 44 South West 

 

2) Add a 5th Column: Temperature Difference 

− In cell E2, enter this formula and drag it down:  = D2-C2 

− E = Max Temp - Min Temp 

− Label the column: Temp Difference 

3) Sort by City (Descending Order) 

− Select the full table including headers. 

− Go to Data > Sort. 

− Sort by: City, Order: Z to A 

4) Sort by Multiple Criteria 

− Select the table. 

− Go to Data > Sort. 

− Add 3 levels: 

− Sort by: Min Temp | Order: Smallest to Largest 

− Then by: Max Temp | Order: Largest to Smallest 

− Then by: City | Order: A to Z 

− Click OK. 

5) Filter Cities with Max Temp Between 30° and 35° 

− Click the filter arrow on the Max Temp column. 

− Choose Number Filters > Between… 

− Enter: Lower: 30 - Upper: 35 

6) Filter Cities in North West with Min Temp = 21° 

− Filter Location column: Select North West 

− Filter Min Temp column: Choose 21 
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Result should include: 

Oran 

Tlemcen 

7) Filter Cities from South or North with Max Temp Between 40° and 45° 

− Filter Location: Select only South and North 

− Filter Max Temp: Number Filters > Between… 

− Lower: 40, Upper: 45 

Matching cities: 

Ghardaïa (South – 41°) 

Ouargla (South – 43°) 

Adrar (South West – 44°) → If you include South West too 

8) Filter Cities That Start with "A" 

− Click the filter arrow in City. 

− Choose Text Filters > Begins With… 

− Type: A 

The  result is: 

Annaba 

Alger 

Adrar 

 

2.4. Conclusion 

Understanding how to use filters and sorting functions in Excel is fundamental to 

efficient data handling. These tools not only simplify the process of finding and organizing 

information but also enhance clarity and decision-making in data analysis. By applying 

appropriate filters and sort orders, users can extract meaningful insights and maintain better 

control over complex datasets. Mastery of these features marks an important step toward 

becoming proficient in Excel and more effective in data-driven tasks. 
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3.1. Introduction 

In Microsoft Excel, cell references are the way Excel identifies and locates data in a 

worksheet. Each cell has a unique address based on its column letter and row number, such 

as A1, B2, or C5. 

These references are essential because Excel needs to know where to pull the data 

from when performing calculations. When you write a formula, it’s not enough to type 

numbers directly; instead, you often refer to cells whose values may change, making the 

spreadsheet dynamic and powerful. 

A typical formula begins with the = symbol to indicate that Excel should evaluate a 

calculation. For example: =A1 + B1. This tells Excel to add the values in cells A1 and B1. 

You can also start a formula with + or - when you begin with a positive or negative number, 

like: +100 - A1 

However, using = is the standard and most universally recognized way to start a 

formula. 

3.2. Types of Cell References 

Excel supports various types of references depending on how you want them to behave 

when you copy formulas. Each has a different use case depending on whether the reference 

should change or remain fixed when copied [7], [8]. 

3.2.1. Relative Reference 

A relative reference adjusts automatically when copied to another cell. This is the 

default behavior in Excel. 

Example: 

Enter values 1 through 5 in cells A1 to A5. 

In cell B1, enter the formula: = (1 + 0.17) * A1 

Press Enter. The result will be calculated for A1. 

Drag the formula down using the fill handle (the small square at the bottom-right 

corner of the selected cell). 

In B2, the formula becomes = (1 + 0.17) * A2 

In B3, it becomes = (1 + 0.17) * A3 



48 
 

This happens because A1 was a relative reference. When the formula was copied 

down, it automatically adjusted the row number. 

The relative reference adjusts based on its position relative to the new location ideal 

for repeated row/column operations like adding tax, multiplying prices, etc. 

3.2.2. Absolute Reference 

An absolute reference remains constant no matter where the formula is copied. This 

type of reference uses the $ symbol before the column and row: $F$1 

This tells Excel: “Always refer to cell F1, no matter where this formula is moved or 

copied.” 

Example: 

In F1, enter 17% to represent a tax rate. 

In B1, enter: = (1 + F1) * A1 

Drag the formula down to B5. 

You’ll notice that the results are incorrect because F1 became F2, F3, etc. 

Now change the formula in B1 to: = (1 + $F$1) * A1 

Copy it down again, now the formula always refers to F1. 

This type of reference is used to lock in a fixed reference (like a constant tax rate, 

currency exchange rate, or fixed parameter) across multiple formula copies. 

3.2.3. Symbolic Reference 

Instead of referring to a cell by its position (like F1 or $F$1), Excel allows to assign a 

name to a cell or range, known as a named reference. 

Example: 

Select cell F1 (which contains 17%). 

Go to the Formulas tab → Define Name. 

Name the cell VAT. 

Now change the formula in B1 to: = (1 + VAT) * A1 
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When copied down, VAT stays the same, it acts like an absolute reference but is more 

readable. 

Pros: 

Improves clarity (=A1 * VAT is easier to read than =A1 * $F$1), 

Easier for non-experts to understand what the formula is doing. 

Cons: 

Requires manual setup, 

Can be confusing if many names are defined. 

3.2.4. Formula with Mixed Reference 

Mixed references are a combination of relative and absolute references. They allow to 

lock only the column or only the row to give precise control when copying formulas. 

Example: 

In worksheet, column A contains values from 1 to 5 (A1:A5), and the price including 

tax (VAT) is calculated in column C using the formula: = (1 + VAT) * A1 

To copy the results from C1:C5 into D1:D5 without changing the outcome. However, 

if the formula is copied, Excel will adjust the reference to A1 based on its relative position, 

turning it into B1, B2, etc. 

This causes incorrect results because the formula no longer points to column A. 

Solution: Use a Mixed Reference 

In cell C1, update the formula to: = (1 + VAT) * $A1 

$A1: The column A is fixed (absolute), but the row remains relative (it will change to 

2, 3, etc. as needed). 

This allows you to copy the formula horizontally or vertically and still refer to column 

A for your values. 

 

 

 



50 
 

Explanation: 

Reference Meaning 

$A1 Fixed column A, changing row 

A$1 Changing column, fixed row 1 

$A$1 Fixed column and row 

A1 Changing column and row (fully relative) 

 

The Mixed references are especially useful when: 

− You are working with tables where calculations apply across rows and 

columns. 

− You want to lock one axis (row or column) while letting the other adjust during 

copying. 

3.2.5. Formula with External Reference 

Sometimes, the data is not located on the same worksheet or even the same workbook. 

In such cases, the use of external references to pull data from other sheets or other files. 

a. External Reference to Another Worksheet 

If the cells are in different sheet in the same workbook, use the sheet name followed 

by an exclamation mark !: = Sheet2!A1 

This formula pulls the value from cell A1 in Sheet2. 

If the sheet name has spaces or special characters, enclose it in single quotes: ='My 

Sheet'!B2 

b. External Reference to Another Workbook 

If the cell is in a different Excel file, you must include: 

− The file name in square brackets [ ], 

− The sheet name and cell reference. 
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Example: 

='[SalesData.xlsx]January'!C5 

This retrieves the value from cell C5 in the January sheet of the workbook 

SalesData.xlsx. 

If the workbook is closed, Excel shows the full file path: 

='C:\Users\John\Documents\[SalesData.xlsx]January'!C5 

c. External Reference and Reference Type 

It is possible to combine relative, absolute, or mixed references with external ones: 

='Sheet2'!$A$1    → Absolute external reference   

='Sheet2'!A$1     → Mixed reference   

='Sheet2'!A1      → Relative reference 

External references are ideal when: 

− The data is split across multiple sheets (e.g., one sheet per month). 

− To consolidate or analyze data from multiple workbooks. 

− To build a summary or dashboard that pulls data from other sources. 

3.3. Summary table of types of cell references  

Reference 

Type 

Example Description Changes 

on Copy? 

Common Use 

Case 

Relative =A1 Both column and 

row adjust when 

copied. 

Yes (row 

and 

column) 

Fast auto-fill 

calculations across 

rows or columns 

Absolute =$A$1 Both column and 

row are fixed. 
 

No 

Referring to a 

constant cell (e.g. 

VAT rate, fixed 

value) 

Mixed 

(row fixed) 

=A$1 Column adjusts, 

row stays fixed. 

 

Column 

only 

Useful when 

copying across 

rows but keeping 

the same row 

Mixed (col 

fixed) 

=$A1 Row adjusts, 

column stays 

fixed. 

 

Row only 

Useful when 

copying down 

columns but 
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keeping the same 

column 

Named 

Reference 

=VAT * A1 Refers to a named 

cell or named 

range instead of a 

letter/number 

combo. 

Name 

doesn’t 

change 

Makes formulas 

easier to read and 

manage 

External 

Reference 

'Sheet2'!A1 Refers to a cell in 

another sheet. 

Depends 

on 

reference 

type 

When data is in 

another worksheet 

External 

Workbook 

'[Sales.xlsx]Jan'!A1 Refers to a cell in 

another workbook. 

Depends 

on 

reference 

type 

Consolidating data 

from multiple files 

 

3.4. Exercises 

3.4.1. Exercise 1 

 

Q) Create the following table in Excel, and then calculate the amount of the discount using 

three different formulas (using three types of reference). 

3.4.2. Exercise 2 

 

Q) Calculate the amount. 
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3.4.3. Exercise 3  

 

Q) Give a single formula for constructing the following multiplication table. 

3.5. Solution of exercises 

3.5.1. Solution of exercise 1 

Formula 1 – Relative Reference 

In cell D6: = B6*B2 

• Then drag the fill handle down to D9. 

• This formula uses relative references, meaning when copied to other cells, the 

references change based on the relative position. 

• But this only works incorrectly here because B2 is above and will shift when dragged. 

To fix it, use absolute or named references in the next formulas. 

Formula 2 – Absolute Reference 

In cell E6: = B6*$B$2 

• Then drag down to E9. 

• $B$2 is an absolute reference, which keeps the discount cell fixed when copying the 

formula. 

Formula 3 – Named Reference 

1. Create a named range for the discount: 

Select cell B2, go to the Name Box (left of the formula bar), and type: 

DiscountRate → press Enter. 
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In cell F6: = B6 * DiscountRate 

• Then drag down to F9. 

• This uses a named reference, making the formula more readable and self-

explanatory. 

3.5.2. Solution of exercise 2 

 In cell C3, type the formula: = $B3*C$2 

• $B3: Locks column B (unit price), allows row to change. 

• C$2: Locks row 2 (quantity), allows column to change. 

Copy this formula: 

• Drag right from C3 to H3 (to apply it for quantities 10–100). 

• Then drag down from C3:H3 to C9:H9 (to apply it for all articles). 

3.5.3. Solution of exercise 3 

In cell B2, type the following formula: = $A2*B$1 

• $A2 → Locks column A (row multiplier), but allows row to change. 

• B$1 → Locks row 1 (column multiplier), but allows column to change. 

Press Enter, then: 

• Drag the formula from B2 to K2 (to fill across). 

• Then drag down from row 2 to 11 (B2:K11) to fill the entire table. 
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3.6. Conclusion 

In conclusion, understanding cell references is fundamental to working efficiently in 

Excel. Throughout this chapter, we learned that relative references (like A1) automatically 

adjust when a formula is copied to another location, making them ideal for repetitive 

calculations across rows or columns. In contrast, absolute references (such as $A$1) remain 

fixed regardless of where the formula is moved, which is especially useful when referring to 

constants like a tax rate or a discount. We also explored mixed references (e.g., $A1 or A$1), 

which allow more control by locking either the row or the column. Additionally, using 

named ranges enhances formula readability and reduces errors, particularly in complex 

spreadsheets. Mastering these reference types not only improves accuracy but also makes 

formulas more scalable and easier to maintain. 
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BASIC EXCEL FUNCTIONS 
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4.1. Definition 

Functions are predefined formulas in Excel that allow users to perform complex 

calculations easily and efficiently. Like regular formulas, every function begins with an 

equal sign (=), indicating that a calculation is to be performed. What makes functions 

particularly powerful is that they can process entire ranges of cells, simplifying tasks that 

would otherwise require long or complex manual formulas. 

For example, instead of adding each cell individually (=A1+A2+A3+A4), you can use 

the SUM function with a cell range (=SUM(A1:A4)), which is clearer, shorter, and easier to 

update. Excel offers a wide variety of functions to handle mathematical, statistical, logical, 

text, date, and financial operations, making it an essential tool for data analysis and 

management. 

Understanding how to use functions is a key step toward becoming proficient in Excel 

and unlocking its full potential. 

4.2. The Different Types of Excel Functions 

Excel functions are grouped into several categories, each designed to perform specific 

types of operations. These include mathematical functions, statistical functions, logical 

functions, date and time functions, text functions, and lookup and reference functions. Each 

function is made up of one or more parameters or arguments, which are the inputs the 

function uses to perform its calculation [9]-[10]. 

For instance, in the function =SUM(A1:A5), the range A1:A5 is the argument, telling 

Excel which cells to add. The flexibility of arguments allows functions to adapt to different 

data structures and needs, whether you’re calculating totals, evaluating conditions, extracting 

parts of text, or finding values in large tables. 

The table below, table 4.1 summarizes some of the most commonly used Excel 

functions, where the parameter cell represents a reference to a specific cell. 

 

 

 

 

 



58 
 

Table 4.1: Basic Excel functions 

Mathematical functions 

SUM(cell1, cell2 , … ) 
Adds all the numbers provided by the arguments. 

 

PRODUCT(cell1, cell2, ... ) Renvoie le produit de tous les nombres fournis par les 

arguments. 

 

QUOTIENT(numerator, 

denominator) 

Returns the integer part of the result of a division. 

INT(cell) Give the integer part of the number. 

ROUND(cell, Number) 
This function rounds a number to a specified number of 

digits. 

− If Number is greater than 0, the number 

argument is rounded to the specified number of 

decimal places.  

− If Number equals 0, the number argument is 

rounded to the nearest whole number.  

− If  Number  is less than 0, the number argument 

is rounded to the left of the decimal point. 

EXP(cell)   

 

Calculates the exponential of the number. 

SQRT (cell) 
Calculates the square root of the number. 

FACT(cell) 
Give the factorial of the number. 

ODD (cell)   
Give a number rounded up to the nearest odd 

number. 
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POWER(cell, n)   Calculates a number to the nth power. 

LN(cell)   

 

Returns the natural logarithm of a number.  

Number must be positive. 

LOG(cell, [base])   

 

Returns the logarithm of a number in the specified base. 

Number must be positive. Base: represents the base of 

the logarithm. If base is omitted, the default value is 10. 

MOD(cell, divisor)   
Gives the remainder (modulo) of the number divided by 

the divisor. 

EVEN(cell)   Rounds a number up to the next even number. 

COMBIN(n , x)   

 

n: is the total number of elements. 

x: is the number of elements in each combination. 

Example: You have 20 candidates to form a team of 15 

people.  We want to know how many different teams are 

possible:    =COMBIN(20,15)     ➔ 15 504. 

MINVERSE (cell range)   

 

Give the inverse of a matrix. 

- Select a range of cells of the same size as the 

argument-matrix.  

- Enter function. 

- Confirm with Ctrl+Shift+Enter. 

TRANSPOSE(cell range)  Returns the transposed matrix. 

MMULT(cell range 1,  cell 

range2)   

Returns the product of matrix1 and matrix2. 

SUBTOTAL(no_fonction , 

cell1, cell2,...) 

 

Returns a subtotal in a list. 

no_fonction : represents the number between 1 and 11 

indicating which function to use to calculate subtotals. 

cell1, cell2, ... represent the ranges on which to calculate 

a subtotal. 
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List of functions: 

1 MOYENNE      2 NB                     3 NBVAL  

4 MAX                5 MIN                   6 PRODUIT  

7 ECARTYPE      8 ECARTYPEP       9 SOMME  

10 VAR              11 VAR.P 

Statistics functions 

AVERAGE(cell1, ...)   

 

Calculates the average of all numerical values provided 

by the arguments. 

MIN(cell1, …)   

MAX(cell1, …)   
Returns the smallest and largest numerical value 

respectively. 

COUNT(cell1, …)   

 
Counts the number of numerical values present in the 

data provided by the arguments. 

COUNTA(cell1, …)   
Counts the number of non-empty values entered in the 

data provided by the arguments. 

COUNTBLANK(cell1, …)   Counts the number of empty cells in the data provided 

by the arguments. 

COUNTIF(cell_range, criteria)  

 

Counts the number of cells in cell_range that meet the 

criteria given as an argument. 

Warning! quotation marks are required when using a 

comparison operator. 

SUMIF(cell_range1, criteria , 

cell_range2) 

This function adds the values of the cell range 

cell_range2 (argument 3) each time a cell in the range 

meets the criterion given as an argument. 

AVERAGEIF(cell_range1, 

criteria, cell_range2) 

Calculates the average of the values in the cell_range2 

(argument 3) each time a range cell meets the criterion 

given as an argument. 
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MEDIAN(cell1, …)   
Calculates the median value of the values supplied by 

the arguments. 

MODE(cell1, …) 
Returns the most frequent or repetitive value in a matrix 

or range of data.  

STDEV(cell1, …)   Calculates the standard deviation of a sample 

STDEVP(cell1, …)   
Calculates the standard deviation of the entire 

population. 

VAR(cell1, …) Calculates the variance based on a sample. 

VARP(cell1, …) 
Calculates the variance based on the whole population. 

RANK(cell, range cell, type)   

 

Calculates the rank of the number supplied as 1st 

argument in the set of values supplied as 2nd argument. 

The type gives the order of ranking: 0 (default value) for 

ranking from highest to lowest value, 1 otherwise. 

FREQUENCY(range_cell,  

interval_matrix ) 

Calculates the frequency of appearance of values in a 

range. 

Logic functions 

The IF function returns a value if the condition you specify is TRUE, and another value if 

it's FALSE. 

IF function syntax: 

IF(condition , expression if  condition true , expression if condition false)  

 

 

Conditions are expressed with the following operators: (=, >, <,>=, <=, <>) 

Conditions are also expressed using appropriate functions to control the state of a cell: 

ISBLANK(cell) Returns TRUE if the value refers to an empty cell. 

ISNUMBER(cell) 
Returns TRUE if the value refers to a numeric value. 

Can be read: then 
Can be read: else 
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ISTEXT(cell) 
Returns TRUE if the value refers to a character string.  

AND(cell1, cell2, …) 
Returns TRUE if all arguments are TRUE, returns 

FALSE if at least one of the arguments is FALSE. 

OR(cell1, cell2 , …) 
Returns TRUE if one argument is TRUE and FALSE if 

all arguments are FALSE. 

Date and time functions 

TODAY ()   

 

Sets the cell to the current date (i.e. today's date if the 

computer is up to date!). 

NOW()   

 

Gives the current date and time. The values is updated 

when the sheet is opened. 

YEAR(Date) Converts date to year number. 

MONTH(Date) Converts date to month number. 

DAY(Date)   Converts date to day number. 

WEEKDAY (Date, type)   
Converts the date into the number of the day of the 

week. 

type: is the number that determines the type of 

information the function returns. 

1: Digit between 1 (Sunday) and 7 (Saturday). 

2: Digit between 1 (Monday) and 7 (Sunday). 

3: Digit between 0 (Monday) and 6 (Sunday). 

HOUR(Date)   

MINUTE(Date)   

SECOND(Date)      

Extracts the numerical value corresponding to the hour, 

minute and second from the date/time data. 

DATE(Year, Month, Day)   

 

Calculate a date from the 3 numerical values supplied 

separately.                                                                                                          

Example: =DATE(YEAR(TODAY()),12,31). 
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DATEDIF(Date1, Date2, unit)   Calculates the difference between date 1 and date 2 

according to the type of units required :  

Unit = "y"  result in number of years. 

Unit = "m" result in number of months. 

Unit = "d"     result in number of days. 

Text functions 

CONCATENATE(cell1,  cell2, 

…)   
Concatenates data from different sources in one cell.  

LEFT(cell, char no) 

 

Returns the first character(s) of a text string according 

to the number of characters you specify. 

RIGHT(cell, char no ) 

 

Returns the last character(s) of a text string according to 

the number of characters you specify. 

REPT(cell, no times) Repeats a text a certain number of times. 

LEN(cell)  Returns the number of characters in a text. 

MID(cell,  start position , 

char_no) 

Extracts a char_no part of the text string from the start 

position.   

UPPER(cell) 

MINUSCULE(cell) 

PROPER(cell) 

Transforms the whole text into uppercase, lowercase or, 

for each word in the text, into uppercase initial and the 

rest of the word into lowercase. 

Search functions 

LOOKUP(search value, search 

range, result range ) 

 

 

if the search value cannot be found, the LOOKUP 

function returns the result value corresponding to the 

nearest lower search value found in the result data range. 

The search range must be sorted. 



64 
 

MATCH(search value, search 

range, type)  

 

The MATCH function returns the position of the search 

value in the search table. The search type is used to 

determine the result to be returned if the data is missing.  

- type = 1 (default value) position of equal or 

lower value ordered in ascending order the 2nd 

argument. 

- type = 0 exact value position  

- type = -1 position of equal or greater value 

ranked in descending order the 2nd argument. 

VLOOKUP(val to search, range, 

column number containing the 

val to be displayed, FALSE ) 

 

 

 

HLOOKUP( val to search, range, 

column number containing the 

val to be displayed, FALSE ) 

Excel looks for the val to search in the leftmost column 

of the range, and displays the corresponding val of the 

column whose number is indicated in the 3rd argument 

(the numbering is 1, 2, 3,... going to the right, knowing 

that 1 is the number of the leftmost column of the range). 

FALSE → exact match 

TRUE → approximate match (data must be                                                                     

sorted) 

VLOOKUP  allows you to search vertically (top to 

bottom), while  HLOOKUP  allows you to search 

horizontally (left to right). 
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4.3. Exercises 

4.3.1. Exercise 1 

  

1) Reproduce the table in an Excel file (tp4.xlsx). This workbook contains several 

sheets, which you will work on successively. 

2) Calculate student averages. 

3) Modify the format of the averages column to display only one figure after the decimal 

point. 

4) Calculate the maximum and minimum grades for the various disciplines. 

5) Create a nice layout for Sheet 1 (add a title, use colors, etc.).  

6) Display the histogram of student grades. 

7) Write a formula to calculate the number of students appearing in the table. 

8) Copy the table from Sheet 1 to Sheet 2. 

9) Write formulas to display adjourned or received in the result column. 

10) What happens if you change some of the marks in the table? 

11) Modifying the formulas in the 'result' column to display 'Adjourned' if the average is 

< 8, 'Received' if it is greater than or equal to 10, and 'Retake' otherwise. 
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12) Add a mention column to display the mention P, QG, and G. If the average is less 

than 10, no mention is displayed.  

13) Write a formula to calculate the number of passes 

14) Calculate the percentage of passes.  

15) Write a formula to calculate the number of students with marks equal to or higher 

than 10 in computer science. 

16) Calculate the number of students with marks equal to or higher than 10 in both French 

and English.  

17) Calculate the average computer science grade of repeaters.  

18) Write a formula that displays the name of the best student in English. 

19) Write a formula that displays the name of the best student in the class. 

4.5.2. Exercise 2 

Consider the following table: 

 

1) Knowing that the customer code is made up of the first 3 letters of the name and the 

first 2 letters of the first name, give the formula used to calculate the code. 

2) Calculate the age of each customer. 

3) Break down the date of birth into year, month and day 

4) Determine the day of the week corresponding to each date of birth. 

5) Determine the position of the person that start on 13/03/2022. 

6) Determine the work corresponding to the name Madani. 
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7) Determine the start date of work 4466. 

4.5.3. Exercise 3 

Consider the following matrix:                                  

 

 

 

 

1) Determine the inverse matrix. 

2) Determine the transpose matrix. 

4.3.4. Exercise 4 

The following table shows monthly revenues by city: 

 

Q) Calculate monthly revenues for each city. 

4.3.5. Exercise 5 

The Human Resources department of the Avionics company, which has two sites: 

Oran and Tlemcen, must prepare the data entry sheets for office automation training over the 

whole of the current year and enter the data that exists, i.e. that for the 1st trimester. Data 

from Oran and Tlemcen will be grouped together in the same workbook as the summary. 

1            2           1 

3            4         -1 

0            2           0 
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Q) Create a workbook containing three sheets, one sheet for data from Oran, another sheet 

for data from Tlemcen and a sheet for the summary. 

4.3.6. Exercise 6 

In an Economics test, graded on 10 points, the students obtained the following marks: 4, 5, 

3, 4, 9, 7, 5, 9, 7, 7, 0, 7.  

1) From the raw data table on the below left, construct the corresponding distribution 

table. Use the FREQUENCY matrix function. 

2) Reproduce the below right table. Determine the frequencies and cumulative 

frequencies, given that: (fi = ni / ∑ni ) ,   (F1 = f1) et (Fi = Fi-1 + fi). 

3) Calculate the average: complete the column ii xf . Then, in F24, perform the sum of 

ii xf  which gives us the average  . 

4) Variance calculation: Complete the column 
2

ii xf  . Then perform the sum of
2

ii xf in 

G24. The variance is obtained by the formula ∑ ii xf 2 – (∑ ii xf )2 

5) What's the difference between the VAR and VARP functions? 

6) Calculate the standard deviation using the definition 
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7) Calculate the average, variance and standard deviation using Excel functions. Round 

the values found to two decimal places. Compare with previous results. 

8) Determine the median of the marks using the Excel function, then check the result 

using the definition. 

9) Represent the initial data, then the data in the distribution table, in a pie chart. 

  

 

4.4. Solution of exercises 

4.4.1. Solution of exercise 1 

2) Calculate Averages: In cell F3: 

= (C3*2 + D3*1 + E3*1) / 4 

Drag down for other students. 

3) Format Averages: Right-click column F → Format Cells → Number → 1 decimal 

place. 

4) Min/Max Grades: Use formulas at the bottom: 

= MIN(C3:C10)   // for Computer Science 

= MAX(C3:C10)   // for Computer Science 

The same for D and E 

5) Improve Layout: Add title, apply colors (headers, alternating rows), use borders. 

6) Histogram: Insert → Chart → Choose “Column” or “Bar” → Data: Averages. 
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7) Count Students: 

= COUNTA(A3:A10) 

8) Copy Table to Sheet2: Right-click Sheet1 → Move or Copy → check “Create a copy”. 

9) Basic Result Logic (in G3): 

=IF(F3>=10, "Received", "Adjourned") 

10) Change Marks: Recalculate all formulas dynamically. 

11) Advanced Result Logic: 

=IF(F3<8, "Adjourned", IF(F3>=10, "Received", "Retake")) 

12) Mention Column (H3): 

=IF(F3<10, "", IF(F3>=16, "G", IF(F3>=14, "QG", "P"))) 

13) Number of Passes: 

= COUNTIF(G3:G10, "Received") 

14) Percentage of Passes: 

= COUNTIF(G3:G10, "Received") / COUNTA(A3:A10) 

15) CS ≥ 10: 

= COUNTIF(C3:C10, ">=10") 

16) French and English ≥ 10: 

= COUNTIFS(D3:D10, ">=10", E3:E10, ">=10") 

17) Average CS grade of Repeaters: 

= AVERAGEIFS(C3:C10, B3:B10, "Yes") 

18) Best in English: 

= INDEX(A3:A10, MATCH(MAX(E3:E10), E3:E10, 0)) 

19) Best Student Overall: 

= INDEX(A3:A10, MATCH(MAX(F3:F10), F3:F10, 0)) 

 



71 
 

4.4.2. Solution of exercise 2 

1) Formula to Calculate Customer Code 

Formula (in A2): 

= LEFT(B2,3) & LEFT(C2,2) 

This combines the first 3 letters of the last name with the first 2 of the first name. 

2) Calculate Age of Each Customer 

Formula (e.g., in H2): 

= DATEDIF(D2, TODAY(), "Y") 

This calculates the age in full years. 

3) Break Down Date of Birth 

Year (e.g., in I2): 

=YEAR(D2) 

Month: 

=MONTH(D2) 

Day: 

=DAY(D2) 

4) Day of the Week for Birth Date 

Formula (e.g., in L2): 

=TEXT(D2, "dddd") 

This returns the weekday name (e.g., Monday). 

5) Find Position (Row) for Start Date = 13/03/2022 

Use this formula in a cell: 

= MATCH(DATE(2022,3,13), G2:G10, 0) 

This returns the relative row number in the range (e.g., 3 if the match is in row 4). 
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To return full data (e.g., name), use: 

=INDEX(B2:B10, MATCH(DATE(2022,3,13), G2:G10, 0)) 

6) Work Corresponding to Name "Madani" 

If multiple results, use FILTER (Excel 365+): 

=FILTER(F2:F10, B2:B10="Madani") 

Or array-enter this (older Excel versions): 

=IFERROR(INDEX(F2:F10, SMALL(IF(B2:B10="Madani", ROW(F2:F10)-

ROW(F2)+1), ROW(1:1))), "") 

7) Start Date for Work Code = 4466 

Formula: 

=INDEX(G2:G10, MATCH(4466, F2:F10, 0)) 

4.4.3. Solution of exercise 3 

1) Enter the Matrix 

Enter the matrix into cells A1:C3: 

A B C 

1 2 1 

3 4 -1 

0 2 0 

2) Transpose the Matrix 

- Select a 3×3 range (e.g., E1:G3) 

- In the formula bar, enter: 

- =TRANSPOSE(A1:C3) 

- Press Ctrl + Shift + Enter  

3) Inverse of the Matrix 

Select another 3×3 range (e.g., E5:G7) 

In the formula bar, type: 

=MINVERSE(A1:C3) 

Press Ctrl + Shift + Enter or just Enter in modern Excel. 
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Format the Result 

• Select the inverse matrix cells. 

• Right-click → Format Cells → Number → Set Decimal Places to 2 or 3 for 

readability. 

4.4.4. Solution of exercise 4 

1. Turn on AutoFilter 

Select the header row (A2:D2) 

Go to the Data tab 

Click Filter 

2. Add SUBTOTAL formulas under the revenue columns 

In cell B12 (below the January column), enter: 

=SUBTOTAL(9, B3:B11) 

9 tells Excel to perform a SUM. 

SUBTOTAL will sum only the visible rows, ignoring hidden (filtered out) ones. 

In C12 and D12, enter: 

=SUBTOTAL(9, C3:C11) 

=SUBTOTAL(9, D3:D11) 

      3. Filter by City 

Click the dropdown in the City column (A2), and filter to show only Oran. 

Now, B12, C12, D12 will display the total revenues for Oran for January, February, 

and March. 

Repeat the filter for Algiers and Tlemcen to view their totals. 

4.4.5. Solution of exercise 5 

    1. Create a New Workbook 

▪ Open Microsoft Excel. 

▪ Create a new blank workbook. 
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▪ Rename the sheets: 

- Right-click on Sheet1 → Rename to Oran 

- Click the + to add a new sheet → Rename to Tlemcen 

- Add a third sheet → Rename it to Summary 

 2. Sheet: Oran 

▪ In the Oran sheet, enter the first table. 

▪ In column E, calculate the row totals: 

In cell E2: =B2+C2+D2 

Drag the formula down to E5. 

▪ In E6, calculate the grand total: =SUM(E2:E5) 

 3. Sheet: Tlemcen 

▪ In the Tlemcen sheet, enter the second table 

▪ Column E (total per row): 

E2: =B2+C2+D2, then drag down to E5 

▪ E6 (grand total): =SUM(E2:E5) 

 

A B C D E 

Training 

Summary 
January February March Total 

Oran =Oran!B2+Oran!B3+

Oran!B4+Oran!B5 

=Oran!C2+C3+C4

+C5 

=Oran!D2+D

3+D4+D5 

=Oran!E6 

Tlemcen =Tlemcen!B2+B3+B4

+B5 

=Tlemcen!C2+C3+

C4+C5 

=Tlemcen!D2

+D3+D4+D5 

=Tlemcen!E6 

Total =B2+B3 =C2+C3 =D2+D3 =E2+E3 

 

4.4.6. Solution of exercise 6 

1) Create Frequency Distribution Table (with FREQUENCY function) 

- Enter the data from B2:B13 (X values). 

- In another range (e.g. D18:D23), define class boundaries (xᵢ values): 0, 3, 4, 5, 7, 9 

- Select a range of 6 cells (C18:C23) for nᵢ (frequencies). 
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- Use the FREQUENCY formula: 

=FREQUENCY(B2:B13, D18:D22) 

Excel will automatically calculate how many values fall into each class. 

2) Compute relative and cumulative frequencies 

- In C18:C23, you'll now have nᵢ 

- In C25: =SUM(C18:C23) → total students = 12 

Column fᵢ (Relative Frequency): 

- D18: =C18/$C$25 

- Fill down (D18:D23) 

Column Fᵢ (Cumulative Frequency): 

- E18: =D18 

- E19: =E18 + D19 

- Drag down to E23 

3) Calculate the average 

Column fᵢ * xᵢ: 

- F18: =D18 * B18 

- Drag down to F23 

In F24: total weighted average 

=SUM(F18:F23) → this is the mean 

4) Variance Calculation 

Column fᵢ * xᵢ²: 

- G18: =D18 * (B18^2) 

- Drag down to G23 

In G24: 
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=SUM(G18:G23) 

Then, use the formula: 

Variance = ∑fᵢ * xᵢ² − (Mean)² 

You can place this formula in B27: 

=G24 - (F24)^2 

5) VAR vs VARP 

Function Meaning Formula 

VAR.S Variance of a sample Divides by (n−1) 

VAR.P Variance of the population Divides by n 

 

In this case, since all students are included (population), use VAR.P. 

6) Standard Deviation 

In B28: 

=SQRT(B27) 

7) Use Excel Built-in Functions 

In the cells: 

- Average: =AVERAGE(B2:B13) 

- Variance: =VAR.P(B2:B13) 

- Standard deviation: =STDEV.P(B2:B13) 

Round results using =ROUND(formula, 2) 

Compare the values with manual calculations from previous steps. 

8) Median 

In B29: 

=MEDIAN(B2:B13) 
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Manual check: Sorted values 

0, 3, 4, 4, 5, 5, 7, 7, 7, 7, 9, 9 

→ Median is average of 6th and 7th: (5 + 7)/2 = 6 

 Matches =MEDIAN(...) 

9) Pie Charts 

Pie Chart from Raw Data: 

- Use column B ("X" values) → Insert > Pie Chart 

Pie Chart from Distribution Table: 

- Use xᵢ and nᵢ (B18:C23) 

- Insert Pie Chart: Insert > Pie Chart using these values 

 

4.5. Conclusion 

Functions in Excel are powerful tools that enhance productivity, accuracy, and 

efficiency in data analysis. They allow users to perform a wide range of tasks, from simple 

arithmetic calculations to complex statistical, logical, and text operations. Understanding 

and using built-in functions such as SUM, AVERAGE, IF, VLOOKUP, INDEX/MATCH, 

and TEXT enables users to manipulate data effectively and make informed decisions. 

Mastery of functions lays the foundation for more advanced Excel skills, including data 

visualization, automation, and financial modeling. By practicing and applying these 

functions, users can unlock Excel’s full potential and handle real-world data challenges with 

confidence. 
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CHAPTER 5 

 

MAIL MERGE 
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5.1. Definition 

Mail merge is a powerful feature used in word processing that enables users to create 

multiple personalized documents from a single template. Instead of manually editing each 

letter or document to address different recipients, mail merge automates the process by 

combining a standard letter with individualized data for each recipient. 

For example, if you want to send a letter to a list of customers, mail merge lets you 

write the letter once and automatically insert each recipient’s name, address, or other 

personal details into the appropriate places in the document. This way, each letter looks 

customized for its specific recipient while saving a tremendous amount of time and effort. 

This process typically involves two main components: 

- The main document: This is the template letter or form where the standard content is 

written, with placeholders or fields where personalized information will be inserted. 

- The data source: This is a database or spreadsheet (commonly created in Excel) that 

contains the personalized details for each recipient, such as names, addresses, phone 

numbers, or any other relevant data. 

Using Word’s mail merge function along with an Excel spreadsheet as the data source 

is a common and efficient way to generate bulk personalized letters, labels, envelopes, 

emails, or other documents. This integration allows users to maintain and update their 

recipient data easily in Excel while managing the document layout and formatting in Word. 

5.2. Steps to Perform Mail Merge Using Word and Excel 

To perform a mail merge [11], [12], you need to carefully follow these steps to link 

your Word document with your Excel database and generate personalized documents 

efficiently. 

5.2.1. Start Word and Create a New Document 

Begin by opening Microsoft Word and creating a new blank document. This document 

will serve as your main document, which contains the general content of your letter or 

message. 

Write the standard text you want all recipients to receive. 

Leave blank spaces or placeholders where personalized information (like name, 

address) will be inserted later from the Excel database. 
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For example, the letter might say: 

Dear [Recipient’s Name], 

where "[Recipient’s Name]" is a placeholder you will replace with the actual recipient's 

name during the merge. 

5.2.2. Open the Mail Merge Tool 

Once your document is ready, navigate to the Tools menu on the Word toolbar. 

Click on Tools and select Mail Merge from the dropdown menu to launch the mail 

merge wizard or panel see figure 5.1. 

This is where you will manage linking your document to your data source. 

 

Figure 5.1. Mail merge. 

5.2.3. Create a Form Letter 

In the mail merge options, choose to Create a new document type. 

Select Form Letter since you are creating personalized letters for multiple recipients. 

This tells Word you want to generate personalized copies of a letter based on your 

template. 
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5.2.4. Choose Active Window 

The next step is to choose the document to use for the merge. 

Select Active Window, which refers to the Word document you currently have open 

(the one with your letter template). 

This links the mail merge process to your existing document. 

5.2.5. Obtain the Data 

Now, to bring in your recipient information, click on Get Data. 

This command lets Word access an external data source, such as an Excel spreadsheet, 

where your list of recipients is stored. 

5.2.6. Open the Data Source 

Select Open Data Source to browse your files and locate the database you want to use. 

This will open a file explorer window to navigate to your saved Excel file. 

5.2.7. Select the Folder Containing Your Excel Database 

In the file explorer dialog, look for the folder where your Excel database is saved. 

Use the Look in field to navigate to that folder for easy access. 

5.2.8. Choose Excel Worksheets as the File Type 

Before selecting the Excel file, set the file type filter: 

In Files of Type, choose MS-Excel Worksheets. 

This will ensure only Excel files appear, making it easier to find your database. 

5.2.9. Select and Open Your Excel Database 

Click on the Excel file containing your recipient list to highlight it, then click Open. 

This action imports your Excel data into Word for the merge. 

5.2.10. Choose Entire Worksheet 

Word will prompt you to specify which part of the Excel workbook to use. 

Select Entire Worksheet to use all the rows and columns from your Excel sheet. 

Click OK to confirm. 
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This allows you to access every recipient’s data for the mail merge. 

5.2.11. Edit the Main Document 

With the data linked, Word now enables the mail merge menu tools. 

You can continue editing your letter and customize where data fields will be placed. 

At this point, you will notice new mail merge options available in the toolbar or menu. 

5.2.12. Insert Data Fields 

Position your cursor in the document where you want to insert personalized data (e.g., 

a recipient’s name or address). 

Click Insert Merge Field to see a list of all the columns (field names) from your Excel 

database, see figure 5.2. 

These represent the pieces of data you can insert. 

 

Figure 5.2. Insert Merge Field. 

5.2.13 Choose a Field to Insert 

Select one of the fields, such as FirstName or City. 

Word will insert a placeholder at the cursor position, which will be replaced with 

actual data during the merge. 

Repeat this process to insert all necessary fields throughout your document. 
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5.2.14. Start the Merge Process 

Once your document is ready with all fields in place, go back to the Tools menu. 

Click on Mail Merge, then select Merge to initiate the process of generating 

personalized letters. 

Word will combine the template with the data for each recipient. 

5.2.15. Complete the Merge 

Finally, click Merge again to complete and finalize the mail merge. 

Word will produce a separate, fully personalized letter for each row of data in your 

Excel file. 

You can then print the letters, save them individually, or send them via email 

depending on your needs. 

5.3. Exercise 

An association needs to create a reminder letter for members who have not paid their 

annual contribution. To do this, you need to create an Excel file of all members, and then 

create a Word template for individual letters to members who have not paid their 

contribution. 

 

1) Create the Excel file above. The "To relaunch" column will automatically be set to 

"yes" when the "Paid on" column is empty. 

2) Create a Word document, with the mailing tool, to send a personalized letter to 

members who have not paid their contribution, using this template. 
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Member: Last name First name  

Address: Address, city  

 

                                                Dear Member 

 

Subject: Payment of your membership fee. 

 

Unless we are mistaken, you owe the sum of ............ AD for your 2023 membership 

fee. 

Please accept, ........................, the expression of our most respectful sentiments. 

 

5.4. Solution of the exercise 

Formula for "To relaunch" Column 

In cell H2 (under "To relaunch"), enter the following formula: 

= IF(G2 = "", "yes", "") 

Then drag it down to apply it to all rows. 

This formula checks if the "Paid on" column (G) is empty. If it is, "yes" appears, otherwise 

it stays blank. 

Word Document for Mail Merge 

We now create a Word template that uses the Excel file to send personalized letters only to 

members who haven't paid. 

1. Prepare the Word Document 

Open a new Word document and write the following, using mail merge fields: 

Member: «Last name» «First name»   

Address: «Adress», «City»   
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                                                        Dear Member, 

 

Subject: Payment of your membership fee. 

Unless we are mistaken, you owe the sum of «Contribution 2023 (AD)» AD for 

your 2023 membership fee.   

Please accept, «Civility», the expression of our most respectful sentiments. 

2. Enter the Table in the Excel File 

-    Open Microsoft Excel. 

-    Enter the following headers in columns A to H: 

Civility, Last name, First name, Adress, City, Contribution 2023 (AD), Paid 

on, To relaunch. 

-    Fill in the table with the members’ data as shown in the image (row by row). 

-    Save the file (e.g., as members_contributions.xlsx). 

3. Connect Excel for Mail Merge 

- In Word, go to Mailings > Select Recipients > Use an Existing List. 

- Choose your Excel file. 

- Select the correct worksheet. 

- Insert merge fields: Insert Merge Field > choose Last name, First name, etc., 

to replace the placeholders. 

4. Filter Only Members to Relaunch 

- Click Mailings > Edit Recipient List. 

- Click Filter. 

- Choose To relaunch > Equals > yes. 

This ensures that only unpaid members receive the letter. 

5. Finish the Mail Merge 
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- Click Finish & Merge. 

- Choose Print Documents or Edit Individual Documents to review and save 

them. 

5.5. Conclusion 

The mail merge chapter demonstrates how Excel and Word can work together to 

streamline the process of creating personalized documents for multiple recipients. By linking 

an Excel database with a Word document, users can efficiently generate customized letters, 

labels, or emails without manually editing each copy. This feature saves significant time and 

effort, especially when dealing with large mailing lists or repetitive correspondence. 

Understanding the steps involved from preparing the data source to inserting merge fields 

and completing the merge empowers users to automate routine communication tasks 

effectively. Overall, mail merge is a valuable tool that enhances productivity and accuracy 

in managing bulk personalized documents. 
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6.1. Introduction 

Macros in Excel are one of the most powerful features available to users who want to 

simplify and accelerate their workflow. They allow you to automate repetitive or routine 

tasks by either recording a sequence of actions or writing a custom program using VBA 

(Visual Basic for Applications), which is Excel’s built-in programming language. 

Imagine performing the same formatting on a spreadsheet every day, adjusting column 

widths, applying colors, inserting formulas, and sorting data. Doing it manually can be 

tedious and error-prone. With a macro, you only need to do it once while recording your 

actions, and then you can replay those steps automatically as many times as you need with 

just a single click or keyboard shortcut. 

For more advanced users, macros can go beyond simple recordings. By writing VBA 

code, you can build dynamic and intelligent automation: loop through data, make decisions 

using conditional statements, interact with other applications like Outlook or Word, and even 

create custom Excel functions. 

6.2. Visual Basic 

Visual Basic for Applications (VBA) is a programming language that allows users to 

write Visual Basic code to control and enhance the functionality of Microsoft Excel [13]. 

When you write a program using VBA in Excel, this program is called a macro. 

6.3. Macro 

A macro is a predefined set of instructions that Microsoft Excel can follow to 

automatically perform a sequence of tasks [14]. Think of it as a personal assistant that 

remembers your exact steps and repeats them exactly the same way quickly, accurately, and 

consistently every time you need. 

6.4. The Usefulness of Macros 

Macros in Excel offer a highly efficient way to streamline work by automating 

repetitive and time-consuming tasks. They reduce human error, ensure consistency across 

reports or operations, and significantly enhance productivity making them an essential tool 

for anyone who works with Excel regularly. 

In daily Excel use, many tasks are repetitive. For instance, you might often: 

- Format a monthly report in a specific style 
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- Copy and paste data from one sheet to another 

- Apply the same formulas to a new dataset 

- Generate charts with identical settings 

- Filter and print results using fixed criteria 

Rather than manually performing these actions over and over again, which takes time 

and increases the risk of errors, you can record a macro once, and Excel will automatically 

repeat the steps whenever you need. 

6.5. The Working Mechanism of a Macro in Excel 

When you create a macro, Excel saves your series of actions as a script, which is either 

recorded automatically (without code) or written in VBA (Visual Basic for Applications). 

Once saved, you can trigger this macro by: 

- Clicking a button in the toolbar 

- Pressing a keyboard shortcut 

- Opening a specific file 

- Running it from the VBA editor 

Example 

Let’s say you format a sales report every week. Each time, you: 

1. Adjust column widths 

2. Bold the headers 

3. Apply currency formatting 

4. Insert a total row at the bottom 

Instead of repeating those steps manually every week, you could record a macro once, 

and with one click, Excel would repeat all of those actions for you instantly. 

6.6. Steps to Create a Macro in Excel (Using the Macro Recorder) 

This is the easiest way to create a macro, no programming knowledge needed. 

1. Open Excel 

- Start with a workbook where you want to automate tasks. 
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2. Enable the Developer Tab  

- Go to File > Options 

- Click Customize Ribbon 

- Check the Developer box, then click OK 

- Click on “Record Macro” 

- Go to the Developer tab 

- Click Record Macro 

3. Name the Macro 

- Enter a macro name (no spaces, use underscores) 

- Optionally, assign a shortcut key (e.g., Ctrl + Shift + M) 

- Choose where to store the macro: 

o This Workbook (for current file) 

o New Workbook 

o Personal Macro Workbook (for all Excel files) 

- Click OK to start recording 

4. Perform the Actions You Want to Automate 

- Excel records every click, selection, formatting, typing, etc. 

5. Click “Stop Recording” 

- Go to the Developer tab 

- Click Stop Recording 

6. Run the Macro 

Once you've recorded your macro, you can run it at any time: 

Option 1: Using the Developer Tab 

- Go to the Developer tab 

- Click Macros 
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- Select the macro name you created 

- Click Run 

Option 2: Using a Keyboard Shortcut 

If a shortcut key is assigned when recording the macro (e.g., Ctrl + Shift + M), just 

press that key combination, and Excel will run the macro instantly. 

Option 3: Using a Button on the Worksheet 

- Go to Developer > Insert > Button (Form Control) 

- Draw the button on your sheet 

- In the pop-up window, assign your macro to the button 

- Click OK 

- Now, clicking that button will run your macro. 

6.7. Steps to Create a Macro Using VBA  

1. Open the Visual Basic Editor 

- Go to the Developer tab 

- Click Visual Basic 

2. Insert a New Module 

- In the left pane (Project Explorer), right-click on your workbook 

- Click Insert > Module 

3. Write Your Macro Code 

Example: 

Sub Economic() 

       MsgBox "Students, in Economic!" 

End Sub 

4. Run the Macro 

- Press F5 inside the editor or 
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- Go back to Excel, open the Macros menu (Developer tab), select your macro, 

and click Run 

6.8. Exercises 

6.8.1. Exercise 1 

1) Create a macro named macro1, which writes the text "ESE" in bold type in cell A1, 

"Student information" in cell B1 and the current date in italics in cell G1.  

2) Create a macro2 that writes the months January, February and March in columns 

from the active cell. Use the macro recorder with relative cell reference.  

3) Record a macro named macro3, which writes the following items: Products, 

Quantities, and Total in column from the active cell. Use the macro recorder with 

relative cell reference.  

4) Record a macro named macro4, which copies the contents of the active cell into the 

cell that is in the same column and 2 rows lower than the active cell. 

6.8.2. Exercise 2 

Reproduce the table given below on an Excel spreadsheet. This table represents 

product sales data for a given company, with the following columns: "Date", "Product", 

"Region", "Quantity" and "Unit price". 

 

1) Create a pivot table to analyze sales quantities by product and region. 

2) Add a calculated field to calculate total revenues for each product/region 

combination. 

3) Add a filter to select a specific product. 

4) Add a segment to view sales by region for a given product. 
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6.9. Solution of exercises 

6.9.1. Solution of exercise 1 

1) Create a macro named macro1 

Click on A1 

- Go to Developer > Record Macro 

▪ Macro name: macro1 

▪ Store in: This Workbook 

▪ Click OK 

- Type ESE and press Enter 

- Click on A1 again, then click Home > Bold (B) 

- Click on B1, type Student information, press Enter 

- Click on G1, type =TODAY() and press Enter 

- While G1 is selected, click Home > Italic (I) 

- Go to Developer > Stop Recording 

Now, running macro1 will perform all the actions above. 

2) Create macro2: Months across columns using relative references 

- Select any blank cell (e.g., C3) 

- Go to Developer > Use Relative References 

- Click Record Macro 

▪ Macro name: macro2 

▪ Store in: This Workbook 

▪ Click OK 

- Type January, press Tab 

- Type February, press Tab 

- Type March, press Enter 
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- Go to Developer > Stop Recording 

Now, you can run macro2 from any starting cell, and it will fill the 3 months across 

columns. 

3) Create macro3: Column titles using relative references 

- Select any blank cell (e.g., D5) 

- Go to Developer > Use Relative References 

- Click Record Macro 

▪ Macro name: macro3 

▪ Store in: This Workbook 

▪ Click OK 

- Type Products, press Enter 

- Type Quantities, press Enter 

- Type Total, press Enter 

- Go to Developer > Stop Recording 

- Running macro3 will list the labels downward from any cell. 

4) Create macro4: Copy to cell two rows below (relative) 

- Select a cell that contains some data (e.g., E2) 

- Go to Developer > Use Relative References 

- Click Record Macro 

▪ Macro name: macro4 

▪ Store in: This Workbook 

▪ Click OK 

- Press Ctrl + C (copy the current cell) 

- Press ↓, ↓ to move down two rows 

- Press Ctrl + V (paste) 
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- Go to Developer > Stop Recording 

- Now, running macro4 from any cell will copy its content 2 rows down. 

6.9.2. Solution of exercise 2 

1) Open your Excel file and enter the table as shown in your image. 

Select the range A1:E5 

Go to Developer > Record Macro 

- Name: CreateSalesPivot 

- Store in: This Workbook 

- Click OK 

2) Insert PivotTable 

- Go to Insert > PivotTable 

- Choose "New Worksheet" 

- Click OK 

           Set up PivotTable 

- Rows: Drag Product 

- Columns: Drag Region 

- Values: Drag Quantity 

         Add Calculated Field 

- Click anywhere in the PivotTable 

- Go to PivotTable Analyze > Fields, Items & Sets > Calculated Field 

- Name: Revenue 

- Formula: =Quantity * 'Unit price' 

- Click Add > OK 

3) Add Filter and Slicer 

- Drag Product into the Filters area 
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- With PivotTable selected, go to PivotTable Analyze > Insert Slicer 

- Select Region > OK 

Stop the Macro 

Go to Developer > Stop Recording 

Result 

Excel has now generated a macro that does everything: 

To Run It Again 

Press Alt + F8, select CreateSalesPivot, and click Run 

View or Edit the Code 

- Press Alt + F11 to open the VBA editor 

- In Modules > Module1, you'll find the recorded macro. 

4)  

- Click anywhere inside your PivotTable. 

- Go to the "PivotTable Analyze" tab on the Excel ribbon (at the top). 

- Click on "Insert Slicer". 

- In the window that appears, check the box for "Region", then click OK. 

- A slicer for regions will appear next to your PivotTable. 

- Click on any region in the slicer to filter sales data for that region. 

- If you also want to filter by product, repeat the steps and insert a slicer for 

"Product". 
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6.10. Conclusion 

The Excel Macros chapter highlights the powerful automation capabilities of 

Microsoft Excel. Macros allow users to record a sequence of actions and replay them 

instantly, making repetitive tasks faster and more consistent. Whether it's formatting data, 

copying values, generating reports, or performing calculations, macros help streamline 

workflows and reduce the risk of manual errors. Behind the scenes, macros use VBA a 

programming language that gives users even greater control and customization over Excel’s 

features. While beginners can easily use the Macro Recorder without writing code, advanced 

users can write or edit VBA code to create more complex and dynamic solutions. Overall, 

learning how to create, record, and run macros equips users with a valuable tool for 

improving efficiency and productivity in Excel. 
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Conclusion 

This handout on Microsoft Excel has offered a well-rounded and structured 

introduction to the essential tools and features needed to work effectively with spreadsheets. 

It began by establishing the fundamental concepts, including how to navigate the interface, 

create and save workbooks, and understand the structure of worksheets composed of cells, 

rows, and columns. These basics form the core knowledge required for any Excel task, 

whether simple or advanced. 

Building on this foundation, the course introduced data organization through sorting 

and filtering. Sorting allows users to arrange data in a meaningful order, alphabetically, 

numerically, or by date, while filtering enables the extraction of specific subsets of data 

based on defined criteria. These tools are crucial when working with large datasets, as they 

help users isolate relevant information quickly and make more informed decisions. 

Understanding cell references was another critical topic. The distinction between 

relative, absolute, and mixed references is essential when writing formulas that need to adapt 

(or remain fixed) as they are copied across the sheet. This concept is the backbone of formula 

efficiency and accuracy in dynamic spreadsheets. 

The handout then explored Excel’s powerful library of functions, which enables users 

to perform a wide range of operations from simple arithmetic to complex statistical and 

logical analysis. Learning how to use functions such as SUM, IF, VLOOKUP, and TEXT 

empowers users to transform raw data into actionable insights and professional reports. 

A practical extension of Excel’s capabilities was introduced with mail merge, which 

connects Excel with Microsoft Word to generate customized letters, labels, or emails. This 

feature is especially useful in administrative contexts, allowing for the automatic 

personalization of documents using data from a spreadsheet. 

Finally, the handout culminated with an introduction to macros and automation. By 

recording macros or using Visual Basic for Applications (VBA), users can automate 

repetitive tasks, reduce errors, and significantly increase productivity. This is especially 

valuable in professional environments where the same processes are performed regularly. 
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